Ячейка F2-(информационная (начало,конец)) — КиберПедия 

Организация стока поверхностных вод: Наибольшее количество влаги на земном шаре испаряется с поверхности морей и океанов (88‰)...

Индивидуальные и групповые автопоилки: для животных. Схемы и конструкции...

Ячейка F2-(информационная (начало,конец))



Первое правило→Условное форматирование→ Использовать формулу для форматируемых ячеек

=$F$2=”начало”

и выбрать цвет и шрифт (цвет желтый и шрифт по умолчанию ) ,

в графе Применяется к добавить

=$F$2

Второе правило→Условное форматирование→Использовать формулу для форматируемых ячеек →набрать формулу =$F$2=”конец”

и выбрать цвет и шрифт (у нас цвет красный и шрифт по умолчанию ) , а также в графе Применяется к добавить

=$F$2

3. Создаем таблицу исходной задачи.

Создается таблица на любом пустом месте листа Excel в виде двух столбиков (Задано слово и Получить слово).

В единственной строке указываем данные задачи (у нас bbab и bbaba).

4. Оформляем таблицу решений.

Ячейка F9-содержимое “Исходное слово

Ячейка G9-содержимое “Метка останова

Ячейка F10-содержимое “bbab

Ячейка G10-содержимое “0

Ячейка F11-


Блок-схема действия формулы представлена на рисунке 20:

 

содержимое F11

=ЕСЛИ($H$2>=СЧЁТЗ($F$11:F11);ЕСЛИ(G10=1;"Конечное слово";ЕСЛИ(ЕЧИСЛО(ПОИСК($B$2;F10;1));ЗАМЕНИТЬ(F10;ПОИСК($B$2;F10;1);ДЛСТР($B$2);$C$2);ЕСЛИ(ЕЧИСЛО(ПОИСК($B$3;F10;1));ЗАМЕНИТЬ(F10;ПОИСК($B$3;F10;1);ДЛСТР($B$3);$C$3);ЕСЛИ(ЕЧИСЛО(ПОИСК($B$4;F10;1));ЗАМЕНИТЬ(F10;ПОИСК($B$4;F10;1);ДЛСТР($B$4);$C$4);ЕСЛИ(ЕЧИСЛО(ПОИСК($B$5;F10;1));ЗАМЕНИТЬ(F10;ПОИСК($B$5;F10;1);ДЛСТР($B$5);$C$5);"стоп")))));"")

 

Необходимо повторить с некоторыми изменениями содержание этой ячейки в ячейках F12-F18 (воспользоваться приемом Excel “протаскивание”).

Необходимо помнить, что адреса ячеек со знаками $ не меняются от протаскивания.

Ячейка G11(метка останова на шаге)-содержимое

=ЕСЛИ(F11="Конечное слово";1;ЕСЛИ(ЕЧИСЛО(ПОИСК($B$2;F10;1));ЕСЛИ(И(ЕЧИСЛО(ПОИСК($B$2;F10;1));ЕТЕКСТ($D$2));1;0);ЕСЛИ(ЕЧИСЛО(ПОИСК($B$3;F10;1));ЕСЛИ(И(ЕЧИСЛО(ПОИСК($B$3;F10;1));ЕТЕКСТ($D$3));1;0);ЕСЛИ(ЕЧИСЛО(ПОИСК($B$4;F10;1));ЕСЛИ(И(ЕЧИСЛО(ПОИСК($B$4;F10;1));ЕТЕКСТ($D$4));1;0);ЕСЛИ(ЕЧИСЛО(ПОИСК($B$5;F10;1));ЕСЛИ(И(ЕЧИСЛО(ПОИСК($B$5;F10;1));ЕТЕКСТ($D$5));1;0);0)))))


Блок-схема действия формулы представлена на рисунке 21:

Заполняем ячейки методом протаскивания для G11÷G18 .

Ячейка E11(шаг с номером)-содержимое

=ЕСЛИ($H$2>=1;"шаг " & ЕСЛИ(ЕПУСТО(F11);"";СЧЁТЗ($F$11:F11));"")

Блок-схема действия формулы представлена на рисунке 22:


Заполняем ячейки методом протаскивания для E11÷E18.

Для ячеек F11÷F18 применим условное форматирование цветом и шрифтом.

Условное форматирование→Использовать формулу для форматируемых ячеек

=$F$11=”Конечное слово”

и выбрать цвет и шрифт (цвет красный и шрифт по умолчанию ) ,

в графе Применяется к добавить

=$F$11:$F$18)

Ячейки G9÷G18 сделать невидимыми для пользователя(это служебная информация для самой программы)→ Формат ячеекЦвет→установить “Белый” (они сольются с фоном ячеек)→Enter.



5. Запускаем программу вводом в ячейку G2 цифры “1” и нажатием клавиши Enter. В соседней ячейке H2 появиться цифра 1 (выполниться первый цикл итераций).

Для продолжения шагов необходимо нажимать многократно клавишу F9 в верхней части клавиатуры компьютера .

Если при оформлении модели программа Excel выдаст предупреждение и недопустимых циклических ссылках, необходимо в Главное меню→Параметры→Формулы→Включить итерационные вычисления (установить шаг итерации 1 (за одно нажатие клавиши F9 будет совершаться один шаг)).

 

 

Ход работы.






Кормораздатчик мобильный электрифицированный: схема и процесс работы устройства...

Опора деревянной одностоечной и способы укрепление угловых опор: Опоры ВЛ - конструкции, предназначен­ные для поддерживания проводов на необходимой высоте над землей, водой...

Механическое удерживание земляных масс: Механическое удерживание земляных масс на склоне обеспечивают контрфорсными сооружениями различных конструкций...

Организация стока поверхностных вод: Наибольшее количество влаги на земном шаре испаряется с поверхности морей и океанов (88‰)...





© cyberpedia.su 2017 - Не является автором материалов. Исключительное право сохранено за автором текста.
Если вы не хотите, чтобы данный материал был у нас на сайте, перейдите по ссылке: Нарушение авторских прав

0.005 с.